Friday, October 15, 2010

Update Manager Ubuntu 10.10 - Error : 407 Proxy Authentication Required

A few days ago, I was upgraded my Ubuntu from 10.04 into 10.10 (Maverick). The update process was smooth at the beginning. I used Alternate CD to upgrade.

After the upgrade finished, I can use my Ubuntu well. Then, I tried to update Ubuntu using Update Manager tool. From this point, the problem began. It said that I have to run partial upgrade. I don't know why. I clicked Run Partial Upgrade. I used my office internet, so I must use internet through proxy.

The Update Manager didn't work. It gave me an error like this :
Error : 407 Proxy Authentication Required
In Ubuntu 10.04 (Lucid Lynx), I can solved this problem using Synaptic Package Manager. Just make sure that Manual Proxy Configuration is setup properly and Authentication parameter is filled. (This proxy configuration can be found from menu Setting --> Preferences -->  Network --> Manual Proxy Configuration)

But in Maverick, I can't do that. Even that parameter is already setup properly, the Update Manager still gave me an error as mention above.

Alhamdulillah, my colleague gave me the solution. I did these steps to make the Update Manager run again.
  1. Open my Terminal / Console
  2. sudo vi /etc/apt/apt.conf
  3. Change this line
Acquire::http::proxy "http://10.0.96.6:8080/";
into 
Acquire::http::proxy "http://user:password@10.0.96.6:8080/";
And everything goes well :D
Post a Comment