Sunday, May 19, 2013

Instalasi PHP 5.3.6 pada Ubuntu 10.04

Moodle versi 2.5 saat ini sudah keluar. Dan dia mensyaratkan minimal PHP versi 5.3.3 agar dapat berjalan. Tetapi, Ubuntu 10.04 datang dengan PHP 5.3.2 di repositorinya. Sehingga, tidak bisa menggunakan apt-get dari repo aslinya.

Untuk itu, saya mengambil PHP versi 5.3.6 dari repo non-official untuk Ubuntu 10.04.
Caranya adalah sebagai berikut :
Pada console, ketikkan :
  1. sudo add-apt-repository ppa:bjori/php5
  2. sudo apt-get update
  3. sudo aptitude show php5
Maka akan muncul informasi :
Package: php5
State: not installed
Version: 5.3.6-8ubuntu0ppa4~lucid1
Priority: optional
Section: php
Maintainer: Hannes Magnusson
Berikutnya, jalankan : sudo aptitude install php5 php5-cli
Tunggu beberapa saat. Setelah selesai, ketik : php -v untuk melihat hasilnya. Maka akan muncul informasi :
PHP 5.3.6-8ubuntu0ppa5~lucid1 (cli) (built: Jun 27 2011 18:35:59)
Copyright (c) 1997-2011 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies
Sip! Berarti instalasi PHP versi 5.3.6 sudah berhasil di Ubuntu 10.04.

Silakan coba aplikasi yang menggunakan PHP, apakah ada dampaknya atau tidak. Sebab, Moodle saya, tiba-tiba terkena dampak Error : Database Connection Failed.

Referensi :
http://www.zalexblog.com/2011/01/07/installing-php-5-3-3-on-ubuntu-10-04/
Post a Comment